通达信换成文华财经的指标源码

下面是通达信 给予的  指标源码的解释通达信换成文华财经的指标源码

输出多止损:最低价的25日偏移移动平均的25日偏移移动平均-(最高价的25日偏移移动平均的25日偏移移动平均-最低价的25日偏移移动平均的25日偏移移动平均)*3.5,线宽为0,画黄色
输出多止盈:(最高价的25日偏移移动平均的25日偏移移动平均-最低价的25日偏移移动平均的25日偏移移动平均)*1+最高价的25日偏移移动平均的25日偏移移动平均,线宽为0,画白色
输出空止损:(最高价的25日偏移移动平均的25日偏移移动平均-最低价的25日偏移移动平均的25日偏移移动平均)*3.5+最高价的25日偏移移动平均的25日偏移移动平均,线宽为0,画黄色
输出空止盈:最低价的25日偏移移动平均的25日偏移移动平均-(最高价的25日偏移移动平均的25日偏移移动平均-最低价的25日偏移移动平均的25日偏移移动平均)*1,线宽为0,画白色
短高H赋值:(20*最高价+19*1日前的最高价+18*2日前的最高价+17*3日前的最高价+16*4日前的最高价+15*5日前的最高价+14*6日前的最高价+13*7日前的最高价+12*8日前的最高价+11*9日前的最高价+10*10日前的最高价+9*11日前的最高价+8*12日前的最高价+7*13日前的最高价+6*14日前的最高价+5*15日前的最高价+4*16日前的最高价+3*17日前的最高价+2*18日前的最高价+20日前的最高价)/210,画蓝色,线宽为1
短低L赋值:(20*最低价+19*1日前的最低价+18*2日前的最低价+17*3日前的最低价+16*4日前的最低价+15*5日前的最低价+14*6日前的最低价+13*7日前的最低价+12*8日前的最低价+11*9日前的最低价+10*10日前的最低价+9*11日前的最低价+8*12日前的最低价+7*13日前的最低价+6*14日前的最低价+5*15日前的最低价+4*16日前的最低价+3*17日前的最低价+2*18日前的最低价+20日前的最低价)/210,画蓝色,线宽为1
D90H赋值:短高H的90日指数移动平均,画红色,线宽为1
D90L赋值:短低L的90日指数移动平均,画红色,线宽为1
D90差赋值:D90H-D90L
D90顶赋值:D90H+D90差*2,画红色,线宽为1
D90底赋值:D90L-D90差*2,画红色,线宽为1
高0赋值:(最高价的25日偏移移动平均的25日偏移移动平均-最低价的25日偏移移动平均的25日偏移移动平均)*1+最高价的25日偏移移动平均的25日偏移移动平均,线宽为1,画白色
低0赋值:最低价的25日偏移移动平均的25日偏移移动平均-(最高价的25日偏移移动平均的25日偏移移动平均-最低价的25日偏移移动平均的25日偏移移动平均)*1,线宽为1,画白色
多头定位赋值:低0>=D90底 AND 高0>=D90顶
空头定位赋值:高0<=D90顶 AND 低0<=D90底
震荡定位赋值:低0>=D90底 AND 高0<=D90顶
短顶赋值:(最高价的25日偏移移动平均的25日偏移移动平均-最低价的25日偏移移动平均的25日偏移移动平均)*2+最高价的25日偏移移动平均的25日偏移移动平均,线宽为2,画绿色
短底赋值:最低价的25日偏移移动平均的25日偏移移动平均-(最高价的25日偏移移动平均的25日偏移移动平均-最低价的25日偏移移动平均的25日偏移移动平均)*2,线宽为2,画绿色
短线收盘赋值:(收盘价-短底)/(短顶-短底)*100000,线宽为2,画红色
短线开盘赋值:(开盘价-短底)/(短顶-短底)*100000,线宽为2,画红色
短线高盘赋值:(最高价-短底)/(短顶-短底)*100000,线宽为2,画红色
短线低盘赋值:(最低价-短底)/(短顶-短底)*100000,线宽为0,画红色
顶1赋值:110000,画黄色,线宽为0
底1赋值:-10000,画黄色,线宽为0
当满足条件多头定位=1时,在顶1和底1位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR000066
当满足条件空头定位=1时,在顶1和底1位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR003300
当满足条件震荡定位=1时,在顶1和底1位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR555555
震荡顶赋值:(短线高盘的25日偏移移动平均的25日偏移移动平均-短线低盘的25日偏移移动平均的25日偏移移动平均)*1+短线高盘的25日偏移移动平均的25日偏移移动平均,DOTLINE,画白色
震荡底赋值:短线低盘的25日偏移移动平均的25日偏移移动平均-(短线高盘的25日偏移移动平均的25日偏移移动平均-短线低盘的25日偏移移动平均的25日偏移移动平均)*1,DOTLINE,画白色
输出做空:80000,画白色,线宽为1
输出做多:20000,画白色,线宽为1
输出中线:50000,画黄色,DOTLINE
输出空损:110000,画洋红色,线宽为2
输出多损:-10000,画洋红色,线宽为2
当满足条件是否最后一个周期时,在108000位置书写文字,画洋红色
当满足条件是否最后一个周期时,在80000位置书写文字,画绿色
当满足条件是否最后一个周期时,在20000位置书写文字,画红色
当满足条件是否最后一个周期时,在-9000位置书写文字,画洋红色
DEA3赋值:(收盘价的3日指数移动平均-收盘价的6日指数移动平均)的9日指数移动平均,画绿色,线宽为2
DEA3B赋值:1日前的DEA3,画白色,线宽为0
DEA33B赋值:(收盘价的3日指数移动平均-收盘价的9日指数移动平均的3日指数移动平均-收盘价的3日指数移动平均-收盘价的9日指数移动平均的9日指数移动平均)的9日指数移动平均,画白色,线宽为0
DEA333B赋值:1日前的DEA33B,画白色,线宽为0
当满足条件DEA3B<DEA3ORDEA333B<DEA33B时,在短线低盘和短线高盘位置之间画柱状线,宽度为0.0,0不为0则画空心柱.,画红色
当满足条件DEA3B<DEA3ORDEA333B<DEA33B时,在短线收盘和短线开盘位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色
当满足条件DEA3<DEA3B时,在短线低盘和短线高盘位置之间画柱状线,宽度为0.0,0不为0则画空心柱.,画绿色
当满足条件DEA3<DEA3B时,在短线收盘和短线开盘位置之间画柱状线,宽度为3,1不为0则画空心柱.,画绿色
白色点多定位1赋值:短线低盘<做多 AND 短线高盘>做多
白色点空定位1赋值:短线高盘>做空 AND 短线低盘<做空
当满足条件白色点多定位1=1时,在短线低盘和做多位置之间画柱状线,宽度为3,0不为0则画空心柱.,画白色
当满足条件白色点空定位1=1时,在短线高盘和做空位置之间画柱状线,宽度为3,0不为0则画空心柱.,画白色
白色点多定位2赋值:短线高盘<做多
白色点空定位2赋值:短线低盘>做空
当满足条件白色点多定位2=1时,在短线低盘和短线高盘位置之间画柱状线,宽度为0.0,0不为0则画空心柱.,画白色
当满足条件白色点多定位2=1时,在短线收盘和短线开盘位置之间画柱状线,宽度为3,0不为0则画空心柱.,画白色
当满足条件白色点空定位2=1时,在短线低盘和短线高盘位置之间画柱状线,宽度为0.0,0不为0则画空心柱.,画白色
当满足条件白色点空定位2=1时,在短线收盘和短线开盘位置之间画柱状线,宽度为3,0不为0则画空心柱.,画白色
多头多定位赋值:做多上穿短线低盘 AND 多头定位=1
多头平定位赋值:短线高盘上穿做空 AND 多头定位=1 AND 震荡定位=0
空头空定位赋值:短线高盘上穿做空 AND 空头定位=1
空头平定位赋值:做多上穿短线低盘 AND 空头定位=1 AND 震荡定位=0
震荡多定位赋值:做多上穿短线低盘 AND 震荡定位=1
震荡空定位赋值:短线高盘上穿做空 AND 震荡定位=1
当满足条件空头平定位=1时,在短线低盘位置画3号图标
当满足条件多头平定位=1时,在短线高盘位置画4号图标
当满足条件多头多定位=1OR震荡多定位=1时,在短线低盘位置画3号图标
当满足条件空头空定位=1OR震荡空定位=1时,在短线高盘位置画4号图标

通达信源码:

多止损:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*3.5,LINETHICK0,COLORYELLOW;
多止盈:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK0,COLORWHITE;
空止损:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*3.5+XMA(XMA(H,25),25),LINETHICK0,COLORYELLOW;
空止盈:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK0,COLORWHITE;
短高H:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
短低L:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H:=EMA(短高H,90),COLORRED,LINETHICK1;
D90L:=EMA(短低L,90),COLORRED,LINETHICK1;
D90差:=D90H-D90L;
D90顶:=D90H+D90差*2,COLORRED,LINETHICK1;
D90底:=D90L-D90差*2,COLORRED,LINETHICK1;
高0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,COLORWHITE;
低0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,COLORWHITE;
多头定位:=低0>=D90底 AND 高0>=D90顶;
空头定位:=高0<=D90顶 AND 低0<=D90底;
震荡定位:=低0>=D90底 AND 高0<=D90顶;
短顶:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2+XMA(XMA(H,25),25),LINETHICK2,COLORGREEN;
短底:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2,LINETHICK2,COLORGREEN;
短线收盘:=(C-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线开盘:=(O-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线高盘:=(H-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线低盘:=(L-短底)/(短顶-短底)*100000,LINETHICK0,COLORRED;
顶1:=110000,COLORYELLOW,LINETHICK0;
底1:=-10000,COLORYELLOW,LINETHICK0;
STICKLINE(多头定位=1,顶1,底1,5,0),COLOR000066;
STICKLINE(空头定位=1,顶1,底1,5,0),COLOR003300;
STICKLINE(震荡定位=1,顶1,底1,5,0),COLOR555555;
震荡顶:=(XMA(XMA(短线高盘,25),25)-XMA(XMA(短线低盘,25),25))*1+XMA(XMA(短线高盘,25),25),DOTLINE,COLORWHITE;
震荡底:=XMA(XMA(短线低盘,25),25)-(XMA(XMA(短线高盘,25),25)-XMA(XMA(短线低盘,25),25))*1,DOTLINE,COLORWHITE;
做空:80000,COLORWHITE,LINETHICK1;
做多:20000,COLORWHITE,LINETHICK1;
中线:50000,COLORYELLOW,DOTLINE;
空损:110000,COLORMAGENTA,LINETHICK2;
多损:-10000,COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,108000,'顶'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,80000,'卖'),COLORGREEN;
DRAWTEXT(ISLASTBAR,20000,'买'),COLORRED;
DRAWTEXT(ISLASTBAR,-9000,'底'),COLORMAGENTA;
DEA3:=EMA((EMA(CLOSE,3) - EMA(CLOSE,6)),9),COLORGREEN,LINETHICK2;
DEA3B:=REF(DEA3,1),COLORWHITE,LINETHICK0; 
DEA33B:=EMA((EMA(EMA(CLOSE,3) - EMA(CLOSE,9),3) - EMA(EMA(CLOSE,3) - EMA(CLOSE,9),9)),9),COLORWHITE,LINETHICK0;
DEA333B:=REF(DEA33B,1),COLORWHITE,LINETHICK0;
STICKLINE(DEA3B<DEA3 OR DEA333B<DEA33B,短线低盘,短线高盘,0.0,0),COLORRED; 
STICKLINE(DEA3B<DEA3 OR DEA333B<DEA33B,短线收盘,短线开盘,3,1),COLORRED;
STICKLINE(DEA3<DEA3B,短线低盘,短线高盘,0.0,0),COLORGREEN; 
STICKLINE(DEA3<DEA3B,短线收盘,短线开盘,3,1),COLORGREEN;
白色点多定位1:=短线低盘<做多 AND 短线高盘>做多;
白色点空定位1:=短线高盘>做空 AND 短线低盘<做空;
STICKLINE(白色点多定位1=1,短线低盘,做多,3,0),COLORWHITE; 
STICKLINE(白色点空定位1=1,短线高盘,做空,3,0),COLORWHITE; 
白色点多定位2:=短线高盘<做多;
白色点空定位2:=短线低盘>做空;
STICKLINE(白色点多定位2=1,短线低盘,短线高盘,0.0,0),COLORWHITE; 
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,3,0),COLORWHITE;
STICKLINE(白色点空定位2=1,短线低盘,短线高盘,0.0,0),COLORWHITE; 
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,3,0),COLORWHITE;
多头多定位:=CROSS(做多,短线低盘) AND 多头定位=1;
多头平定位:=CROSS(短线高盘,做空) AND 多头定位=1 AND 震荡定位=0;
空头空定位:=CROSS(短线高盘,做空) AND 空头定位=1;
空头平定位:=CROSS(做多,短线低盘) AND 空头定位=1 AND 震荡定位=0;
震荡多定位:=CROSS(做多,短线低盘) AND 震荡定位=1;
震荡空定位:=CROSS(短线高盘,做空) AND 震荡定位=1;
DRAWICON(空头平定位=1,短线低盘,3);
DRAWICON(多头平定位=1,短线高盘,4);
DRAWICON(多头多定位=1 OR 震荡多定位=1,短线低盘,3);
DRAWICON(空头空定位=1 OR 震荡空定位=1,短线高盘,4);
不同软件的函数处理机制不同,加载效果略有差异是正常的,请理解
参考:

HH:=H;
LL:=L;
多止损:=REFX1(MA(LL,25),25/2)-(REFX1(MA(HH,25),25/2)-REFX1(MA(LL,25),25/2))*3.5,NODRAW,COLORYELLOW;
多止盈:=(REFX1(MA(HH,25),25/2)-REFX1(MA(LL,25),25/2))*1+REFX1(MA(HH,25),25/2),NODRAW,COLORWHITE;
空止损:=(REFX1(MA(HH,25),25/2)-REFX1(MA(LL,25),25/2))*3.5+REFX1(MA(HH,25),25/2),NODRAW,COLORYELLOW;
空止盈:=REFX1(MA(LL,25),25/2)-(REFX1(MA(HH,25),25/2)-REFX1(MA(LL,25),25/2))*1,NODRAW,COLORWHITE;
短高H:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
短低L:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;

D90H:=EMA(短高H,90),COLORRED,LINETHICK1;
D90L:=EMA(短低L,90),COLORRED,LINETHICK1;
D90差:=D90H-D90L;
D90顶:=D90H+D90差*2,COLORRED,LINETHICK1;
D90底:=D90L-D90差*2,COLORRED,LINETHICK1;
高0:=(REFX1(MA(HH,25),25/2)-REFX1(MA(LL,25),25/2))*1+REFX1(MA(HH,25),25/2),LINETHICK1,COLORWHITE;
低0:=REFX1(MA(LL,25),25/2)-(REFX1(MA(HH,25),25/2)-REFX1(MA(LL,25),25/2))*1,LINETHICK1,COLORWHITE;
多头定位:=低0>=D90底 AND 高0>=D90顶;
空头定位:=高0<=D90顶 AND 低0<=D90底;
震荡定位:=低0>=D90底 AND 高0<=D90顶;
短顶:=(REFX1(MA(HH,25),25/2)-REFX1(MA(LL,25),25/2))*2+REFX1(MA(HH,25),25/2),LINETHICK2,COLORGREEN;
短底:=REFX1(MA(LL,25),25/2)-(REFX1(MA(HH,25),25/2)-REFX1(MA(LL,25),25/2))*2,LINETHICK2,COLORGREEN;
短线收盘:=(C-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线开盘:=(O-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线高盘:=(H-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线低盘:=(L-短底)/(短顶-短底)*100000,NODRAW,COLORRED;
顶1:=110000,COLORYELLOW,NODRAW;
底1:=-10000,COLORYELLOW,NODRAW;
STICKLINE1(多头定位=1,顶1,底1,5,0),COLOR000066;
STICKLINE1(空头定位=1,顶1,底1,5,0),COLOR003300;
STICKLINE1(震荡定位=1,顶1,底1,5,0),COLOR555555;
震荡顶:=(REFX1(MA(短线高盘,25),25/2)-REFX1(MA(短线低盘,25),25/2))*1+REFX1(MA(短线高盘,25),25/2),POINTDOT,COLORWHITE;
震荡底:=REFX1(MA(短线低盘,25),25/2)-((REFX1(MA(短线高盘,25),25/2))-REFX1(MA(短线低盘,25),25/2))*1,POINTDOT,COLORWHITE;
做空:80000,COLORWHITE,LINETHICK1;
做多:20000,COLORWHITE,LINETHICK1;
空损:110000,COLORMAGENTA,LINETHICK2;
多损:-10000,COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,108000,'顶'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,80000,'卖'),COLORGREEN;
DRAWTEXT(ISLASTBAR,20000,'买'),COLORRED;
DRAWTEXT(ISLASTBAR,-9000,'底'),COLORMAGENTA;
DEA3:=EMA((EMA(CLOSE,3) - EMA(CLOSE,6)),9),COLORGREEN,LINETHICK2;
DEA3B:=REF(DEA3,1),COLORWHITE,NODRAW; 
DEA33B:=EMA((EMA(EMA(CLOSE,3) - EMA(CLOSE,9),3) - EMA(EMA(CLOSE,3) - EMA(CLOSE,9),9)),9),COLORWHITE,NODRAW;
DEA333B:=REF(DEA33B,1),COLORWHITE,NODRAW;
STICKLINE(DEA3B<DEA3 OR DEA333B<DEA33B,短线低盘,短线高盘,0.0,0),COLORRED; 
STICKLINE(DEA3B<DEA3 OR DEA333B<DEA33B,短线收盘,短线开盘,3,1),COLORRED;
STICKLINE(DEA3<DEA3B,短线低盘,短线高盘,0.0,0),COLORGREEN; 
STICKLINE(DEA3<DEA3B,短线收盘,短线开盘,3,1),COLORGREEN;

白色点多定位1:=短线低盘<做多 AND 短线高盘>做多;
白色点空定位1:=短线高盘>做空 AND 短线低盘<做空;
STICKLINE1(白色点多定位1=1,短线低盘,做多,3,0),COLORWHITE; 
STICKLINE1(白色点空定位1=1,短线高盘,做空,3,0),COLORWHITE; 
白色点多定位2:=短线高盘<做多;
白色点空定位2:=短线低盘>做空;
STICKLINE1(白色点多定位2=1,短线低盘,短线高盘,0.0,0),COLORWHITE; 
STICKLINE1(白色点多定位2=1,短线收盘,短线开盘,3,0),COLORWHITE;
STICKLINE1(白色点空定位2=1,短线低盘,短线高盘,0.0,0),COLORWHITE; 
STICKLINE1(白色点空定位2=1,短线收盘,短线开盘,3,0),COLORWHITE;
多头多定位:=CROSS(做多,短线低盘) AND 多头定位=1;
多头平定位:=CROSS(短线高盘,做空) AND 多头定位=1 AND 震荡定位=0;
空头空定位:=CROSS(短线高盘,做空) AND 空头定位=1;
空头平定位:=CROSS(做多,短线低盘) AND 空头定位=1 AND 震荡定位=0;
震荡多定位:=CROSS(做多,短线低盘) AND 震荡定位=1;
震荡空定位:=CROSS(短线高盘,做空) AND 震荡定位=1;
DRAWICON(空头平定位=1,短线低盘,3);
DRAWICON(多头平定位=1,短线高盘,4);
DRAWICON(多头多定位=1 OR 震荡多定位=1,短线低盘,3);
DRAWICON(空头空定位=1 OR 震荡空定位=1,短线高盘,4);
超长k线数据案例一:超长k线数据测试 量化交易

超长k线数据案例一:超长k线数据测试

前言 问题一:超长的K线数据有什么用? 以上期所的螺纹钢合约为例,螺纹钢2009年挂牌交易至今,已经有超过10年的历史数据。前8年的历史数据囊括了2009年的急涨急跌行情、2011年的震荡行情、201...